This site uses cookies! Learn More

Utilizziamo i cookie per personalizzare i contenuti e gli annunci, fornire le funzioni dei social media e analizzare il nostro traffico. Inoltre forniamo informazioni sul modo in cui utilizzi il nostro sito alle agenzie pubblicitarie, agli istituti che eseguono analisi dei dati web e ai social media nostri partner.

Visualizza dettagli: italiaunix.com/cookies

Per proseguire con la navigazione del sito, devi accettare di utilizzare i nostri cookie :)

Accedi per seguire questo  
Followers 0
Chaosphere

Errore compilazione

1 risposta in questa discussione

Ciao :D

è ormai da qualche giorno che tento di installare Labview su linux. Per fare questo, ho installato Fedora sul mio HD.

Ok, allora, io lancio l' installazione usando questo comando:


[root@localhost chaos]# sh /home/chaos/LabView-2010-linux-rpm/INSTALL

il risultato è questo:

LabVIEW 2010 for Linux/x86

Copyright (c) 2010, National Instruments Corporation.  The source code of this

product is unpublished, unlicensed, and a proprietary trade secret of National

Instruments Corporation.  Decompilation or other reduction of this object code

to human-readable form is prohibited by the license agreement between National

Instruments Corporation and the lawful user or possessor of this copy.

	  Restricted Rights Legend

Use, duplication, or disclosure by the United States Government is subject to

restrictions set forth in subparagraph (c)(1)(ii) of the Rights in Technical

Data and Computer Software Clause at DFARS 252.227-7013 and FAR 52.227-19 (c).

		 National Instruments Corporation

	   11500 N. Mopac Expwy.

	    Austin, Texas 78759

	    U.S.A.


By installing LabVIEW software packages, you agree to the terms of the included

NI Software License Agreement (LICENSE.txt). Type 'v' to view the agreement,

'y' to consent to the agreement, or 'n' to decline the agreement and skip

LabVIEW installation.  [Vynq] y

NOTE: LabVIEW will install by default in /usr/local/natinst/LabVIEW-2010, or

in the natinst/LabVIEW-2010 subdirectory if you specify an alternate location.

Preparing for installation...

C runtime library (glibc) version: 2.16.

WARNING: It does not appear that your are running GNU C Library version 2.2.4

		 or later.  glibc-2.4.4 is required to upgrade.  See the README file

		 for information on how to upgrade this library.

Red Hat Package Manager (RPM) version: RPM versione 4.10.2.

Please indicate whether you would like to install the following components:

labview-2010-rte: LabVIEW Run-Time Engine

[Ynasq?] y

labview-2010-core: LabVIEW Application and VI Library

[Ynasq?] y

labview-2010-examples: LabVIEW VI Examples

[Ynasq?] y

labview-2010-help: LabVIEW On-line Reference Manual

[Ynasq?] y

labview-2010-ref: LabVIEW Manuals in Adobe Acrobat (.pdf) format

[Ynasq?] y

labview-2010-desktop: LabVIEW KDE and GNOME desktop support

[Ynasq?] y

labview-2010-appbuild: LabVIEW Run-Time Application Builder

[Ynasq?] y

labview-2010-pro: LabVIEW Professional Developers Tools

[Ynasq?] y

Auto-selecting dependency niwebpipeline20_dep-2.0-5.i586.rpm

The following components will be installed using rpm:

LabVIEW Run-Time Engine							 112450 kB

LabVIEW Application and VI Library				  556794 kB

LabVIEW VI Examples								 37322 kB

LabVIEW On-line Reference Manual				    79069 kB

LabVIEW Manuals in Adobe Acrobat (.pdf) format	  1825 kB

LabVIEW KDE and GNOME desktop support			   307 kB

LabVIEW Run-Time Application Builder			    82659 kB

LabVIEW Professional Developers Tools			   7457 kB

NI Web Pipeline dependency libraries			    5432 kB

Total space required: 883315 kB

Space available:	  17165276 kB

Proceed? [Ynq] y

Installing...

Preparazione in corso...			  ################################# [100%]

Aggiornamento / installazinone...

   1:labview-2010-rte-10.0.0-1	    ################################# [100%]

errore: estrazione archivio fallita sul file /usr/local/lib/LabVIEW-2010/liblvrt.so.10.0.0;5100375e: cpio: Digest non corrispondente

errore: labview-2010-rte-10.0.0-1.i386: installa fallito

errore: Dipendenze fallite:

libgcc_s.so.1 necessario a niwebpipeline20_dep-2.0-5.i586

libgcc_s.so.1(GCC_3.0) necessario a niwebpipeline20_dep-2.0-5.i586

libz.so.1 necessario a niwebpipeline20_dep-2.0-5.i586

errore: Dipendenze fallite:

labview-2010-rte necessario a labview-2010-core-10.0.0-1.i386

*** ERROR installing packages.

Check that you have enough disk space and that the target filesystem

is writable.


Would you like to install NI Example Finder (LabVIEW 2010)? [Ynq] ^C

[root@localhost chaos]#

Ho pensato che avendo la 64 bit, forse cerca le librerie nella cartella /lib e non /lib64, quindi ho dato da terminale:

[root@localhost chaos]# ln -s /lib64/libbz2.so.1 /lib/libbz2.so.1

[root@localhost chaos]# ln -s /lib64/libgcc_s.so.1 /lib/libgcc_s.so.1

Ma non è cambiato niente. Qualche suggerimento su cosa fare?

Condividi questo messaggio


Link di questo messaggio
Condividi su altri siti

Crea un account o accedi per lasciare un commento

You need to be a member in order to leave a comment

Crea un account

Iscriviti per un nuovo account nella nostra community. È facile!


Registra un nuovo account

Accedi

Sei già registrato? Accedi qui.


Accedi Ora
Accedi per seguire questo  
Followers 0

  • Chi è Online Visualizza tutti

    Non ci sono utenti registrati online

  • Risposte

    • FreeBSD vs OpenBSD: quale preferite?
      FreeBSD o OpenBSD? Semplicità d'uso, diffusione, e flessibilità, oppure sicurezza estrema? Io personalmente ho messo le mani solo sul primo, ma sono molto tentato di provare il secondo. Ditemi le vostre opinioni, esperienze, e gli usi che ritenete siano più adatti ad ognuno!
    • FreeBSD vs OpenBSD: quale preferite?
      FreeBSD o OpenBSD? Semplicità d'uso, diffusione, e flessibilità, oppure sicurezza estrema? Io personalmente ho messo le mani solo sul primo, ma sono molto tentato di provare il secondo. Ditemi le vostre opinioni, esperienze, e gli usi che ritenete siano più adatti ad ognuno!
    • Calcolare le potenze in C
      Grazie della dritta, ho risolto 
    • Calcolare le potenze in C
      Potrei sbagliarmi ma non dovresti compilare linkando il riferimento alla libreria math? (-lm come argomento a gcc sd non erro)
    • [ARTICOLO]KDE Neon UE 5.6 rilasciato
      Per chi non lo sapesse, KDE Neon è una distribuzione realizzata direttamente dal team di KDE, è attualmente basata su Ubuntu 16.04 LTS e il suo obiettivo è fornire all'utente finale un ambiente KDE-centrico sempre aggiornato all'ultima versione possibile. Se volete provarla sul fondo troverete il link di download, ma vi avviso che non è ancora una distribuzione adatta all'uso quotidiano: Per maggiori informazioni: KDE Neon KDE Neon Download Fonte.
      Visualizza tutto articolo